Umap-learn installed, but 'import umap' hangs

Anaconda on Windows 11. From Anaconda Powershell, the ‘umap’ package is installed:

> conda install -c conda-forge umap-learn
Collecting package metadata (current_repodata.json): done
Solving environment: done
# All requested packages already installed.

‘conda list’ shows:
umap-learn 0.5.3 py39hcbf5309_0 conda-forge

However, in Python

Python 3.9.13 (main, Aug 25 2022, 23:51:50) [MSC v.1916 64 bit (AMD64)] :: Anaconda, Inc. on win32
>>> import umap

(never returns)

There are other systems on this machine that use their own versions of Python installed elsewhere, git and github client for example, wondering if that is a problem.

Problem solved. I had earlier installed “Miniconda3” as a user, then installed “Anaconda3” system-wide, and I presume that was the problem. I uninstalled everything (there was 16.6 GB in my user Miniconda3 folder), rebooted, and reinstalled Anaconda3 as a user. Now it works as expected.

1 Like

It works! I installed anaconda system wide. After uninstalling the anaconda and reinstalled as a user, the issue is solved.
I assume it is the lateset version of numba causing the problem.