"this version of python seems to be incorrectly compiled"

Following along with the Getting Started with Anaconda videos, in the process of working with Jupytr I ran

conda install ipykernel


python -m ipykernel install --user --name=envname

which yielded this error: “this version of python seems to be incorrectly compiled. (internal generated filenames are not absolute.) This may make the debugger miss breakpoints.”

the version of python is 3.11.4

this is all I can find online about this particular issue with conda and jupytr, and it remains unanswered (from two months ago, with version 3.11.2): conda - CRITICAL WARNING: Python Version Compiled Incorrectly using Miniconda and Jupyter Lab - Stack Overflow

what should I do here / how do I fix this? thanks for any help you can provide

1 Like

Hi! This sounds like a problem, but it is only a warning that would only cause problem in rare cases.

The reason this happens is due to the way conda works. Because we can never know where files will be installed on a user’s system, we compile our packages with relative path names (./lib/python/ipykernel instead of /usr/local/lib/python/ipykernel) which allows conda to find the libraries in arbitrary subdirectories, rather than hard coding specific file locations.

Thank you for responding. I’ve already reinstalled Anaconda with default everything, so hopefully this won’t come up again.

Thanks, that’s good to know. Do you know how to solve this issue? Even it it’s just a warning, I’d rather it not come up every time I run some code. I’ve tried re-installing Anaconda, but that didn’t solve the issue.