Error updating conda

I have been dealing with installing conda on Windows. Once finished, if I try to upgrade to the latest version with the instructions:
conda update conda
or with
conda update -n base conda
In both cases the update ends with an error that apparently causes the coda commands to not work.
However, in both of the above cases, at the beginning of the process and before pressing “y” to continue, the screen displays:
Please update conda by running
$ conda update -n base -c defaults conda
If I now proceed to update using this command, the process finishes successfully.
Perhaps it would be possible to update the conda update prompts that appear in the CheatSheet or on the web page that opens after conda installation to avoid the reported bugs until they are resolved.

Good morning,

Thank you so much for contacting us, can you please send us more information about the error that you are seeing and the operating system that you are using?

A screenshot or the error message would be very helpful, we are happy to assist you.

Thank you for your interest, Carlos
I did a miniconda install on Windows 10 with the installer downloaded from Miniconda — conda documentation
Following the recommendation, I tried to upgrade conda with the command
conda update conda
, after pressing “y” an error occurs whose text I didn’t save, sorry.
However, when I tried again and before pressing “y”, I noticed that at the beginning of the explanatory text it was indicated,

Collecting package metadata (current_repodata.json): done
Solving environment: done

==> WARNING: A newer version of conda exists. <==
current version: 23.3.1
latest version: 23.5.0

Please update conda by running

$ conda update -n base -c defaults conda

Or to minimize the number of packages updated during conda update use

 conda install conda=23.5.0

Package Plan

environment location: C:\Users\solis\miniconda3

added / updated specs:
- conda

The following packages will be downloaded:

package                    |            build
boltons-23.0.0             |     pyhd8ed1ab_0         296 KB  conda-forge
brotli-1.0.9               |       hcfcfb64_8          19 KB  conda-forge


I interrupted the update by pressing “n” and started the process again using the indicated command
conda update -n base -c defaults conda
the update was executed correctly.
I am not an expert user, so the only way to reproduce the error would be to do another installation and run
conda update conda
to save the error message and repeat the process I have described.
Now the installation works fine for me and I prefer not to have to start over again
The reason for reporting the bug is that it seems to have an easy workaround using
conda update -n base -c defaults conda
but this command is not the one listed in the more accessible documentation
The list of packages in my base environment (I have not installed anything here) is:


packages in environment at C:\Users\solis\miniconda3:

Name Version Build Channel

boltons 23.0.0 py310haa95532_0
brotlipy 0.7.0 py310h2bbff1b_1002
bzip2 1.0.8 he774522_0
ca-certificates 2023.01.10 haa95532_0
certifi 2023.5.7 py310haa95532_0
cffi 1.15.1 py310h2bbff1b_3
charset-normalizer 2.0.4 pyhd3eb1b0_0
colorama 0.4.6 py310haa95532_0
conda 23.5.0 py310haa95532_0
conda-content-trust 0.1.3 py310haa95532_0
conda-package-handling 2.1.0 py310haa95532_0
conda-package-streaming 0.8.0 py310haa95532_0
console_shortcut_miniconda 0.1.1 haa95532_1
cryptography 39.0.1 py310h21b164f_0
idna 3.4 py310haa95532_0
jsonpatch 1.32 pyhd3eb1b0_0
jsonpointer 2.1 pyhd3eb1b0_0
libffi 3.4.4 hd77b12b_0
menuinst 1.4.19 py310h59b6b97_0
openssl 1.1.1t h2bbff1b_0
packaging 23.0 py310haa95532_0
pip 23.0.1 py310haa95532_0
pluggy 1.0.0 py310haa95532_1
powershell_shortcut_miniconda 0.0.1 haa95532_1
pycosat 0.6.4 py310h2bbff1b_0
pycparser 2.21 pyhd3eb1b0_0
pyopenssl 23.0.0 py310haa95532_0
pysocks 1.7.1 py310haa95532_0
python 3.10.10 h966fe2a_2
requests 2.29.0 py310haa95532_0
ruamel.yaml 0.17.21 py310h2bbff1b_0
ruamel.yaml.clib 0.2.6 py310h2bbff1b_1
setuptools 65.6.3 py310haa95532_0
six 1.16.0 pyhd3eb1b0_1
sqlite 3.41.2 h2bbff1b_0
tk 8.6.12 h2bbff1b_0
toolz 0.12.0 py310haa95532_0
tqdm 4.65.0 py310h9909e9c_0
tzdata 2023c h04d1e81_0
urllib3 1.26.15 py310haa95532_0
vc 14.2 h21ff451_1
vs2015_runtime 14.27.29016 h5e58377_2
wheel 0.38.4 py310haa95532_0
win_inet_pton 1.1.0 py310haa95532_0
wincertstore 0.2 py310haa95532_2
xz 5.4.2 h8cc25b3_0
zlib 1.2.13 h8cc25b3_0
zstandard 0.19.0 py310h2bbff1b_0