Conda run -n option not working


I installed last week in centos7 linux via:


Then if I do:

conda activate pflowML
python --version
Python 3.9.15

The latter is what I installed inside pflowML after creating it. Whilst if I try to go via the conda run command I get the default python on the computer, not the one in the virtual environment:

conda run -n pflowML python --version
Python 2.7.5

I believe the “-n” option is supposed to ensure the command runs in the virtual environment. After a lot of googling I could not seem to find anyone else who has come across this behaviour. Does someone know what I am not understanding about this? (e.g I need to make sure some environment variable is correctly set for conda run -n?)

Thanks! Mark