Can't install bowtie2 or BWA using bioconda

Hi,

I just installed miniconda3. I created a new environment “mappingV1” for mapping my sequence reads to the genome. When I tried to install bowtie2 or BWA using bioconda, it gave me the error message “Solving environment: failed with initial frozen solve. Retrying with flexible solve.” I searched a number of discussions about this and I only haven’t tried to downgrade the bioconda to a lower version yet. My current bioconda version is 4.13.0, and I read that I have to downgrade it to 4.6.0. I wonder whether this is really necessary. Whether there is any alternative way to fix this problem?

Thanks,
Bibo

1 Like

Most likely you will need to downgrade as mentioned to version 4.6.0. The reason for this is that you have other packages installed in the same environment that depend on the older version bioconda.

One way to get around this issue would be to first use:

conda list

to get a list of all packages installed in your current environment.

Then create a new environment where you install bioconda 4.13.0 first, then install python 3.10, and then install the other packages you need in this enviroment from the previous list(but newer versions).

Hope this helps.