Anaconda wont start after installing

Hi, I am new to Anaconda and tried to run Anaconda Navigator after instailling.

But keeping getting the errors from the image above.

Like this:
Traceback (most recent call last):
File “D:\Anaconda3\Scripts\”, line 10, in
File “D:\Anaconda3\lib\site-packages\anaconda_navigator\app\”, line 112, in main
File “D:\Anaconda3\lib\site-packages\anaconda_navigator\utils\”, line 216, in clean_logs
if to_datetime(line[‘time’], LOG_TIME_FORMAT) < week_ago:
File “D:\Anaconda3\”, line 268, in
_TimeRE_cache = TimeRE()
File “D:\Anaconda3\”, line 182, in init
self.locale_time = LocaleTime()
File “D:\Anaconda3\”, line 69, in init
self.lang = _getlang()
File “D:\Anaconda3\”, line 28, in _getlang
return locale.getlocale(locale.LC_TIME)
File “D:\Anaconda3\lib\”, line 590, in getlocale
localename = _setlocale(category)
locale.Error: locale query failed

What do I need to do to correct this error?


Looks like you are running Anaconda on a Windows machine with a non-US locale setting.
Is that correct?

I would suggest trying to add US or United States locale to your computer.

These steps might work for you:

View the System Locale settings for Windows
  1. Click Start then Control Panel
  2. Click Clock, Language and Region
  3. Windows 10, Windows 8: Click Region
    Windows 7: Click Region and Language
    Windows XP: Click Regional and Language Options
    The Region and Language options dialog appears.
  4. Click the Administrative tab
    On Windows XP, click the Advanced tab
    If there is no Advanced tab, then you are not logged in with administrative privileges.
  5. Under the Language for non-Unicode programs section, click Change system locale and select the desired language.
  6. Click OK
  7. Restart the computer to apply the change.

Yes, your guess is correct :slightly_smiling_face:

I was using a machine with non-US locale setting.

Now everything seems fine now, thanks a lot.