Anaconda install on REL8

Trying to install the latest Anaconda on REL8 and it errors out with:
Unpacking payload …
./ line 407: 5658 Done(141) { dd if="$THIS_PATH" bs=1 skip=16057510 count=15194 2> /dev/null; dd if="$THIS_PATH" bs=16384 skip=981 count=36169 2> /dev/null; dd if="$THIS_PATH" bs=1 skip=608665600 count=15144 2> /dev/null; }
5659 Segmentation fault (core dumped) | “$CONDA_EXEC” constructor --extract-tar --prefix “$PREFIX”
./ line 409: 5665 Segmentation fault (core dumped) “$CONDA_EXEC” constructor --prefix “$PREFIX” --extract-conda-pkgs

I tried several older versions and still no joy. Any help?

I’ll post the answer just in cast anyone else runs into this. I installed RHEL8 with the DISA STIG profile. This is what caused the issue. It installs fapolicyd, which "Setting and enforcing a policy that either allows or denies application execution based on a rule set efficiently prevents the execution of unknown and potentially malicious software. "

So instead of a nice error message, I received the above message. Also, the STIG profile mounts the /tmp directory with the NOEXEC option. Fun stuff.

1 Like