Anaconda 2023 fails to install from SCCM to a computer with Sysmon installed

Attempting to upgrade our current Anaconda 2019 to the latest 2023.09 release, deploying as an Application from SCCM using the Powershell script below and the python.exe as detection method.

2019 uses the same script/detection and installs just fine on any computer.

2023 also installs just fine when installed with the executable or Powershell script manually, as well as deploying to a computer without Sysmon 15.

The install only fails when deploying Anaconda 2023 from SCCM to a computer with Sysmon installed, returning with 0x87D00324 for a failed detection method. AppEnforce.log shows the install only occurs for 6-7 minutes before terminating with exit code 0 and performing app detection. At this point, only a couple files have been installed and the rest never continue, python.exe included, which is why the detection method keeps failing because python.exe is never installed. (I’ve even tried other files and registries as detection method and same result)

Powershell script:
$args = “/S /InstallationType=AllUsers /RegisterPython=1 /AddToPath=1 /D=C:\Anaconda”
Start-Process -FilePath .\Anaconda3-2023.09-0-Windows-x86_64.exe -ArgumentList $args -Wait -NoNewWindow -PassThru

Only these files get installed:
conda-meta (directory)
Lib (directory)
pkgs (directory)